При установке программ из пакетов пакетного менеджера, или устанавливая программу с помощью Flatpak, все зависимости устанавливаются автоматически, но при запуске программы с каких-нибудь торрентов, каких-то необходимых библиотек может не оказаться в системе.

Спасибо пользователю chibiko c rutracker за инструкцию, как легко найти необходимый пакет в Debian-like системах.

1) Устанавливаем apt-file:

sudo apt-get install apt-file

2) Обновляем его списки пакетов:

sudo apt-file update

3) И ищем нужные библиотеки:

sudo apt-file search libSDL2_image-2.0.so.0

 

libsdl2-image-2.0-0: /usr/lib/x86_64-linux-gnu/libSDL2_image-2.0.so.0
libsdl2-image-2.0-0: /usr/lib/x86_64-linux-gnu/libSDL2_image-2.0.so.0.0.0

Теперь нам стало ясно, что пакет, который нам нужен = libsdl2-image-2.0-0.

Linux
196
0
Добавление комментария (отменить)
  • *Псевдоним:
  • *Код подтверждения:Введите код с картинки, для проверки, что вы не робот.